(61)
Average rating 9.18032786885246 out of 10 ( based on 61 reviews )

Robobrew 3 rocks

Review by Robert Hansler on 7/11/2019

4 brews so far, all came out as expected. Unit is easy to setup, use and clean. Had no issues with the provided immersion cooler as others have indicated. There are many You Tube videos on the Robobrew recommend watching several of those to get tips on use.

Pump comes loose

Review by Douglas on 7/2/2019

First, I want to say that I really love Williams Brewing. Their customer service is fantastic and always does what it takes to make their customers happy. Here's my experience: first Robobrew came dented in numerous places. I contacted WB customer service and they gave me a credit. Unfortunately, when I went to clean the unit before first brew, I found that it was leaking and I couldn't find the source of the leak. I did hear something rattling around the bottom, so I opened it up and found that the pump is attached to a bracket and that nut/bold connection comes loose easily. (I couldn't find the leak.) I was sent a new unit. I've brewed 1 brew with this unit. After cleaning, I heard the same sound in the bottom. I took it apart and found the same issue: the pump's vibrations loosened both connection nuts. There should be some type of washer to prevent this. I found it amazing that the same issue occurred in both units. I like this product. I hope it lasts.

Great Product and Great Customer Experience

Review by Andy on 3/31/2019

This electric brewing system is top notch. No issues whatsoever keeping a rolling boil. The pump has enough power for anything that you might need it for. The experience with williamsbrewing was great. I had a minor issue and it was quickly corrected.

Robo Brew Review

Review by Terry Sprung on 3/19/2019

Have only used once, but so far so good. Slow to heat strike water and to boil after mash, but I knew that going in. Trade off for 110 system you can use anywhere. Worked exactly like it is supposed to. Over all I like it very much.

Failure in less than 1 year of use

Review by Justin on 2/12/2019

My robobrew failed in less than 15 brews. The boards on the unit burnt up. I was promptly sent new ones that I was assured were upgraded. As it turns out, the boards I received were not the correct upgraded ones (this was verified by the manufacturer). After a lot of unproductive back and forth, I was left to purchase the upgraded boards from a different supplier. This has been a regrettable and costly purchase. William's Responds: Kegland sent us some old board by mistake mixed into our last shipment. You were unfortunate enough to get one of these, but we have contacted KegLand, and we making sure only the new boards are in our inventory. Sorry for the problem on this one!